Advertisements

HPOM – UXMON: There were no valid peers!

I was receiving this incident from HPOM

Node : linuxnode.setaoffice.com
Node Type : Intel/AMD x64(HTTPS)
Severity : minor
OM Server Time: 2014-01-21 12:20:43
Message : UXMON: There were no valid peers!
Msg Group : OS
Application : ntpmon
Object : ntpq
Event Type :
not_found

Instance Name :
not_found

Instruction : This message shows athe ntpq has problems to contact
with the NTPD daemon. Is posible the NTP Daemon is down

Please, contact with your UX expert

Took a look at the log file and it was showing that is a problem with NTP

root@linuxnode:/ # tail /var/opt/OV/log/OpC/ntp_mon.log
Tue Jan 21 15:34:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 16:08:16 2014 : working peer “172.16.4.198”, offset(255.81) greater than NTP_OFFSET_WARNING(230), please check!
Tue Jan 21 16:59:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 17:16:17 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 17:33:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 18:41:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 19:49:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 20:06:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 21:14:16 2014 : NTP Problems. There were no valid peers!
Tue Jan 21 21:31:16 2014 : NTP Problems. There were no valid peers!

Apparently it is not synchronizing with more than one peer

root@linuxnode:~ # ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
172.23.72.50 .INIT. 16 u – 16 0 0.000 0.000 0.000
172.23.72.51 .INIT. 16 u – 16 0 0.000 0.000 0.000
172.23.72.52 .INIT. 16 u – 16 0 0.000 0.000 0.000
172.16.4.198 172.23.72.51 4 u 16 16 3 52.630 5.543 4.069

Edit /etc/ntp.conf and insert new NTP servers

root@linuxnode:~ #vi /etc/ntp.conf
#
#server 172.23.72.50 version 3 minpoll 4 maxpoll 4
server 142.40.238.18 version 3 minpoll 4 maxpoll 4
#server 172.23.72.51 version 3 minpoll 4 maxpoll 4
server 142.40.238.19 version 3 minpoll 4 maxpoll 4
#server 172.23.72.52 version 3 minpoll 4 maxpoll 4
server 142.40.236.20 version 3 minpoll 4 maxpoll 4
server 172.16.4.198 version 3 minpoll 4 maxpoll 4

Restart NTP

root@linuxnode:~ # /etc/init.d/ntp restart
Shutting down network time protocol daemon (NTPD) done
Try to get initial date and time via NTP from ntp.setaoffice.com done
Starting network time protocol daemon (NTPD) done

Then checking again the results

root@linuxnode:~ # ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
142.40.238.18 142.40.234.152 3 u 2 16 1 0.476 51.879 0.001
142.40.238.19 142.40.238.18 4 u 1 16 1 0.406 50.896 0.001
142.40.236.20 .INIT. 16 u – 16 0 0.000 0.000 0.001
172.16.4.198 .INIT. 16 u – 16 0 0.000 0.000 0.001

root@linuxnode:~ # ntpq -p
remote refid st t when poll reach delay offset jitter
==============================================================================
142.40.238.18 142.40.234.152 3 u 14 16 1 0.476 51.879 0.001
142.40.238.19 142.40.238.18 4 u 13 16 1 0.406 50.896 0.001
142.40.236.20 172.22.248.13 5 u 12 16 1 0.173 49.724 0.001
172.16.4.198 172.23.72.51 4 u 11 16 1 52.181 53.676 0.001

Advertisements
%d bloggers like this: