Advertisements

Problems updating firmware on QLogic QLE2460, QLE2462 and QMH2462 on HP Proliant

I’m having problems updating the firmware on fibre channel HBA cards QLE2460, QLE2462 QMH2462.

For example, this server has a single channel 4Gb QLE2460 and dual channel 4Gb QLE2462

root@linux01:~ # cat /sys/class/scsi_host/host*/model*name
QLE2462
QLE2462
QLE2460

root@linux01:~ # cat /sys/class/scsi_host/host*/model*desc
PCI-Express Dual Channel 4Gb Fibre Channel HBA
PCI-Express Dual Channel 4Gb Fibre Channel HBA
PCI-Express Single Channel 4Gb Fibre Channel HBA

root@linux01:~ # lspci -k | grep -A2 -i fibre
22:00.0 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 02)
Subsystem: QLogic Corp. Device 0138
Kernel driver in use: qla2xxx

22:00.1 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 02)
Subsystem: QLogic Corp. Device 0138
Kernel driver in use: qla2xxx

25:00.0 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)
Subsystem: QLogic Corp. Device 0137
Kernel driver in use: qla2xxx

Following the instruction on Updating firmware on an Emulex or QLogic Fibre Channel HBA on HP Proliant and downloaded the file CP022840.scexe

root@linux01:~ # ./CP022840.scexe
—————————————————
Loading references…done.
Performing discovery…
WARNING! : No supported adapters found.

Checking the log file, it shows that no adapters found and gives return code 7

root@linux01:~ # cat /var/cqp/Component.log
=================================================================

Installation started: Thu Nov 5 18:12:09 BRST 2015

Installing: CP022840.scexe
Version: 2014.09.01
Description: HP Firmware Flash for QLogic Fibre Channel HBA’s (x86_64)

—————————————————
Loading references…done.
Performing discovery…
WARNING! : No supported adapters found.

Return code: 7

Installation complete: Thu Nov 5 18:12:09 BRST 2015

=================================================================

On this other server I have a QMH2462 and I had the same problem

root@linux02:~ # cat /sys/class/scsi_host/host*/model*name
QMH2462
QMH2462
root@linux02:~ # cat /sys/class/scsi_host/host*/model*desc

root@linux02:~ # lspci -k | grep -A2 -i fibre
09:00.0 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)
Subsystem: Hewlett-Packard Company Device 1705
Kernel driver in use: qla2xxx

09:00.1 Fibre Channel: QLogic Corp. ISP2432-based 4Gb Fibre Channel to PCI Express HBA (rev 03)
Subsystem: Hewlett-Packard Company Device 1705
Kernel driver in use: qla2xxx

root@linux02:~ # cat /var/cpq/Component.log
=================================================================

Installation started: Fri Oct 9 12:09:36 BRT 2015

Installing: CP022840.scexe
Version: 2014.09.01
Description: HP Firmware Flash for QLogic Fibre Channel HBA’s (x86_64)

—————————————————
Loading references…done.
Performing discovery…
WARNING! : No supported adapters found.

Return code: 7

Installation complete: Fri Oct 9 12:09:36 BRT 2015

=================================================================

I think the solution will be to update the firmware offline using the HP SPP DVD and selecting Firmware update

Advertisements
%d bloggers like this: