Advertisements

Suse Linux 10 SP2 – rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by

If you try to install or update a package and the following error message appears

root@suselinux10sp2:~ # rpm -Uvh supportutils-1.20-81.1.noarch.rpm
warning: supportutils-1.20-81.1.noarch.rpm: Header V3 DSA signature: NOKEY, key ID 823559f0
error: Failed dependencies:
rpmlib(PayloadIsLzma) <= 4.4.6-1 is needed by supportutils-1.20-81.1.noarch

You need to verify if the compression method is supported by rpm.

root@suselinux10sp2:~ # rpm —showrc | grep Payload
rpmlib(PayloadIsBzip2) = 3.0.5-1
rpmlib(PayloadFilesHavePrefix) = 4.0-1

In this machine, only bzip2 is supported. One work-around is to update the rpm package before trying to install/upgrade the package where the error message appeared.

Advertisements
%d bloggers like this: