Increasing a JFS2 filesystem on AIX

First you need to know which filesystem that you’ll resize. Get the logical volume

root@aix:/ # df -m /u04
Filesystem MB blocks Free %Used Iused %Iused Mounted on
/dev/lvcrnstore 34816.00 1892.34 95% 103 1% /u04

With this information you type lslv lvcrnstore to find out about the volume group that this logical group is part of. Check if there are FREE PPs to extend the filesystem

root@aix:/ # lsvg oraclevg
VOLUME GROUP: oraclevg VG IDENTIFIER: 000d400c00004c00000000fd81379ca3
VG STATE: active PP SIZE: 256 megabyte(s)
VG PERMISSION: read/write TOTAL PPs: 531 (135936 megabytes)
MAX LVs: 256 FREE PPs: 17 (4352 megabytes)
LVs: 15 USED PPs: 514 (131584 megabytes)
OPEN LVs: 14 QUORUM: 2
TOTAL PVs: 1 VG DESCRIPTORS: 2
STALE PVs: 0 STALE PPs: 0
ACTIVE PVs: 1 AUTO ON: yes
MAX PPs per PV: 1016 MAX PVs: 32
LTG size: 128 kilobyte(s) AUTO SYNC: no
HOT SPARE: no BB POLICY: relocatable

Resize the filesystem and check the new size

root@aix:/ # chfs -a size=+4G /u04
Filesystem size changed to 79691776

root@aix:/ # df -m /u04
Filesystem MB blocks Free %Used Iused %Iused Mounted on
/dev/lvcrnstore 38912.00 5987.71 85% 103 1% /u04

Notice that the number of free PPs decreased since you used to increase the filesystem

root@aix:/ # lsvg oraclevg
VOLUME GROUP: oraclevg VG IDENTIFIER: 000d400c00004c00000000fd81379ca3
VG STATE: active PP SIZE: 256 megabyte(s)
VG PERMISSION: read/write TOTAL PPs: 531 (135936 megabytes)
MAX LVs: 256 FREE PPs: 1 (256 megabytes)
LVs: 15 USED PPs: 530 (135680 megabytes)
OPEN LVs: 14 QUORUM: 2
TOTAL PVs: 1 VG DESCRIPTORS: 2
STALE PVs: 0 STALE PPs: 0
ACTIVE PVs: 1 AUTO ON: yes
MAX PPs per PV: 1016 MAX PVs: 32
LTG size: 128 kilobyte(s) AUTO SYNC: no
HOT SPARE: no BB POLICY: relocatable

Advertisement