Advertisements

Keeping a particular version of a package in Red Hat Enterprise Linux

Adding a version lock for the packages shown below

root@linux:~ # yum versionlock libsmbclient libwbclient samba-client samba-client-libs samba-common samba-common-libs samba-common-tools samba-libs
Loaded plugins: changelog, langpacks, product-id, search-disabled-repos,
: subscription-manager, versionlock
This system is registered with an entitlement server, but is not receiving updates. You can use subscription-manager to assign subscriptions.

Adding versionlock on: 0:libsmbclient-4.6.2-12.el7_4
Adding versionlock on: 0:libwbclient-4.6.2-12.el7_4
Adding versionlock on: 0:samba-client-4.6.2-12.el7_4
Adding versionlock on: 0:samba-client-libs-4.6.2-12.el7_4
Adding versionlock on: 0:samba-common-4.6.2-12.el7_4
Adding versionlock on: 0:samba-common-libs-4.6.2-12.el7_4
Adding versionlock on: 0:samba-common-tools-4.6.2-12.el7_4
Adding versionlock on: 0:samba-libs-4.6.2-12.el7_4
versionlock added: 8

Listing the packages that are under version lock

root@linux:~ # yum versionlock list
Loaded plugins: changelog, langpacks, product-id, search-disabled-repos,
: subscription-manager, versionlock
This system is registered with an entitlement server, but is not receiving updates. You can use subscription-manager to assign subscriptions.

0:libsmbclient-4.6.2-12.el7_4.*
0:libwbclient-4.6.2-12.el7_4.*
0:samba-client-4.6.2-12.el7_4.*
0:samba-client-libs-4.6.2-12.el7_4.*
0:samba-common-4.6.2-12.el7_4.*
0:samba-common-libs-4.6.2-12.el7_4.*
0:samba-common-tools-4.6.2-12.el7_4.*
0:samba-libs-4.6.2-12.el7_4.*
versionlock list done

Advertisements
%d bloggers like this: